Ongoing incident affecting our services

Incident Report for Argyle

Resolved

Incident has been resolved.
Posted Aug 16, 2022 - 03:38 CDT

Investigating

We are currently investigating the issue.
Posted Aug 16, 2022 - 03:21 CDT
This incident affected: Link and Console.