External Infrastructure Vendor Issues
Incident Report for Argyle
Resolved
Issues have been resolved.
Posted Sep 13, 2023 - 12:34 CDT
Investigating
We are observing issues with an external infrastructure vendor.
There is no client impact, but we are monitoring the situation closely.
Posted Sep 13, 2023 - 10:10 CDT